Get in touch
Back
Maintenance

Cloud communication platform improvements

Completed 11 Jun at 04:00pm CEST.

Cloud Cloud - Console Management sites
Completed

Maintenance completed

Posted 11 Jun at 04:00pm CEST.
Started

We are working to make Controller connections to the cloud more reliable.

Posted 11 Jun at 10:30am CEST.